Welcome to Animus Talk

This is where users of Animus Heart can share ideas,
solve problems and inspire fellow enthusiasts.

Animus Heart?

Any chance that Fibaro Universal Sensor / Smart Implant will be added

This question did come up in an other topic, without any response, so I ask here.

Does anyone know if there is a plan to implement Fibaro Universal Sensor / Smart Implant with the :animusheart: ?

Fibaro Universal Sensor / Smart Implant are the answer for some my projects and if this is a dead end with :animusheart: I need to go with an other controller.

The Fibaro Universal Sensor is already supported. The Smart Implant I don’t know actually, but it feels that they haven’t done much different there.

I verified it at the Animus test-room. We had one there (more precisely FGBS-001, EU v2.1), so I tried adding it to the system and it worked just fine. I powered it up with a 24V adapter. The manual said between 9-30V.

I have never used them in an actual project, so what exactly is the use case for you?

I want to use the possibility to add tempsensors DS18B20 (universal sensor 4 ds18b20 / smart implant 6 ds18b20).

I can add FGBS-001 to :animusheart: but i can only see the two potential-free inputs, i can not see the four temperature sensors i have connected. When i added my FGBS-001 to a tellstick the four temperature sensors were visible direct.

What must i do to read the values of the temperature sensors (ds18b20)?

Hi

Same here, what to have the temperature sensors to work, thanks.

Karl

Hm, okej, well I got the same result when I tried without a temp sensors. But I advised with one of the developers inside that was working on that integration long ago. He mentioned that the pairing has to be done after the temp-sensors are all connected only. Apparently there was some tinkering that had to be done in order to get it in properly.
So, to make sure if it works or not maybe you could try these steps:

  1. exclude the device completely from other z-wave networks
  2. connect all the temp sensors to the device and power it up
  3. keep the device close to the Heart and start an automatic pairing (inclusion)
  4. once pairing done, check if it entered correctly. If not; go to settings/package controller/z-wave package/ and make a ‘rebuild’ of the node.
  5. now check again if the sensors are showing.

I have excluded the device and included it. The only thing I see is Root Device, Endpoint 1 and Endpoint 2.
So i Rebuild the device… No, no temp sensors.

I have a couple of times when I doubted my self, excluded the device and brought it to a friend that have a Tellstick. Inclusion is simple and every time the temperature sensors is visible. And yes, I have excluded it from the Tellstick mesh network every time before I brought it home and included it in my Heart z-wave mesh network.

Is there anything I can “ask” the node via the developer terminal? to get any smarter?

I will not give up, but I need help.

I excluded the FGBS-001. I included it. No temperature value anywhere.

I rebuild the node. (see below for info from terminal)

But here is some rows:

no driver for DAL, ; what driver is missing?

And

ServiceEvent REGISTERED ; these “ServiceEvent” I believe is the sensors. Why no temperature anywhere?

nfo 2019-09-05 20:21:37 #bid13 - device found, DAL, sid=276, bid=171
info 2019-09-05 20:21:37 #bid171 - ServiceEvent REGISTERED
info 2019-09-05 20:21:37 #bid13 - no driver for DAL, sid=276, bid=171
info 2019-09-05 20:21:38 #bid171 - ServiceEvent REGISTERED
info 2019-09-05 20:21:38 #bid171 - ServiceEvent REGISTERED
info 2019-09-05 20:21:38 #bid171 - ServiceEvent REGISTERED
info 2019-09-05 20:21:38 #bid171 - ServiceEvent REGISTERED
info 2019-09-05 20:21:38 #bid171 - ServiceEvent REGISTERED

info 2019-09-05 20:21:34 #bid171 - Node25: Connected socket
info 2019-09-05 20:21:35 #bid171 - Node25: Started Connection
info 2019-09-05 20:21:35 #bid171 - Device null: Interview process started
info 2019-09-05 20:21:36 #bid129 - Automation: “Taket köket av” was triggered
info 2019-09-05 20:21:37 #bid171 - Node25: was interrupted. Closing the receiver completly
info 2019-09-05 20:21:37 #bid171 - Node25: Closed connection
info 2019-09-05 20:21:37 #bid161 - Device removed: com.animushome.heart.packages.zwave.devices.010F-25
info 2019-09-05 20:21:37 #bid13 - device lost, DAL, sid=270, bid=171
info 2019-09-05 20:21:37 #bid171 - ServiceEvent UNREGISTERING
info 2019-09-05 20:21:37 #bid171 - ServiceEvent UNREGISTERING
info 2019-09-05 20:21:37 #bid171 - ServiceEvent UNREGISTERING
info 2019-09-05 20:21:37 #bid171 - ServiceEvent UNREGISTERING
info 2019-09-05 20:21:37 #bid171 - ServiceEvent UNREGISTERING
info 2019-09-05 20:21:37 #bid171 - ServiceEvent UNREGISTERING
info 2019-09-05 20:21:37 #bid171 - Node25: was interrupted. Closing the receiver completly
info 2019-09-05 20:21:37 #bid26 - Created JsonStorageNode: /var/notifications/b6c76508-3c37-4e90-90a6-50509e578f77 [ com.animushome.heart.service.notifications.NotificationModel ]
info 2019-09-05 20:21:37 #bid171 - Node25: Closed connection
info 2019-09-05 20:21:37 #bid26 - Returning writer for node: /var/notifications/b6c76508-3c37-4e90-90a6-50509e578f77
info 2019-09-05 20:21:37 #bid26 - Returning writer for: /var/ah/framework/datastorage/com.animushome.heart.service.notifications.impl/var/notifications/b6c76508-3c37-4e90-90a6-50509e578f77.data.json
info 2019-09-05 20:21:37 #bid155 - Trying notification: { “id”: “b6c76508-3c37-4e90-90a6-50509e578f77”, “title”: “Device Information”, “message”: “Device Universalsensor was removed.”, “confirmationAlert”: null, “type”: “INFORMATION”, “timestamp”: “1567707697822”, “seen”: false}
info 2019-09-05 20:21:37 #bid171 - Node25: Connected socket
info 2019-09-05 20:21:37 #bid171 - Node25: Started Connection
info 2019-09-05 20:21:37 #bid161 - New device detected: com.animushome.heart.packages.zwave.devices.010F-25
info 2019-09-05 20:21:37 #bid13 - device found, DAL, sid=276, bid=171
info 2019-09-05 20:21:37 #bid171 - ServiceEvent REGISTERED
info 2019-09-05 20:21:37 #bid13 - no driver for DAL, sid=276, bid=171
info 2019-09-05 20:21:38 #bid171 - ServiceEvent REGISTERED
info 2019-09-05 20:21:38 #bid171 - ServiceEvent REGISTERED
info 2019-09-05 20:21:38 #bid171 - ServiceEvent REGISTERED
info 2019-09-05 20:21:38 #bid171 - ServiceEvent REGISTERED
info 2019-09-05 20:21:38 #bid171 - ServiceEvent REGISTERED
info 2019-09-05 20:21:38 #bid26 - Created JsonStorageNode: /config/69782710-740c-4475-9b65-e4c15a9ee038 [ com.google.gson.JsonObject ]
info 2019-09-05 20:21:38 #bid26 - Returning writer for node: /config/69782710-740c-4475-9b65-e4c15a9ee038
info 2019-09-05 20:21:38 #bid26 - Returning writer for: /var/ah/framework/datastorage/com.animushome.heart.packages.zwave/config/69782710-740c-4475-9b65-e4c15a9ee038.data.json
info 2019-09-05 20:21:45 #bid26 - Returning writer for node: /config/69782710-740c-4475-9b65-e4c15a9ee038
info 2019-09-05 20:21:45 #bid26 - Returning writer for: /var/ah/framework/datastorage/com.animushome.heart.packages.zwave/config/69782710-740c-4475-9b65-e4c15a9ee038.data.json
info 2019-09-05 20:21:45 #bid171 - Device 25: Interview process done

Does it make any difference if you only connect 1 temp sensor?

I’m looking to use the smart implant as well, and need two one for temp sensor in the other for controlling my pellet boiler.
How long are the temp sensors connected and how long are the cables?

I have tried only one, no different. When I synced my FGBS-001 to a tellstick the temperature sensors show up fine. So I know I have connected them correctly.

Do you do a reset every time you chance back?
What about firmware is that the latest as well on the Fibaro?

You are not using the Smart Implant but the universal sensor? Any tried to see if they act the same?