Welcome to Animus Talk

This is where users of Animus Heart can share ideas,
solve problems and inspire fellow enthusiasts.

Animus Heart?

D-link cameras

Hi,
I have two d-link cameras that I would like to add to :animusheart:

I see two d-link cameras in the list of supported products, but not my models.

In add new device it seems there is only support for Foscam and Other. I have been trying both but cannot find my cameras.

Has anyone setup d-link cameras? Any suggestions?

/Frode

Hi @frodeatifs, first of all, do you know if these cameras support RTSP? If no, then the answer will probably be “it’s not possible”.

If yes, then I would use the “other”-guide and go for manual setup.
Make sure your camera is in the same network and type in the IP-address, port and path. This has been tried?
Sometimes you might need to make changes in the camera settings to open the RTSP on your camera.

Also adding what camera models they are could help solve your questions faster.

Hi have the D-link DCS-8010LH, but having the same problem.

In the speccs it says that it has RTSP, but i think it’s not activated.

Hi @kristoffer.hanquist and welcome! First of we need to check that your dlink camera are able to send stream through rtsp. I only googled a couple of minutes but it seems like it depends on which firmware you have in the camera… Over 2.0 dlink have disabled the rtsp-function. Strange :thinking:

If you have that firmware its hard to help you out since it doesn’t seems to be a way to downgrade either and :animusheart: (and most 3-party applications overall) uses rtsp to stream over network.

any suggestion on cameras that works with animus? other than axxis or foscam

I have 4 d-links (relatively old) and 2 reolinks working - all were configured via ‘other’.

2 Likes

Step1: Make sure you are on the same network, I had cameras / heart on 2.4 and 5ghz respectively :slight_smile:

After fixing this it was a piece of cake using ‘Other’. I had to enter IPs manually, scanning did not help. I used suggested port and path. Luckily I found an old note for cameras username/pwd.

The camera-streams are available but it seems I cannot take advantage of sound or motion-detectors.

I have modern cameras 8525lh and 8300lh. Seems they are compatible with IFTTT and even Philips Hue which I may experiement with on some rainy day. Even Google Home and Alexa are compatible but I don’t have those.

/Frode

2 Likes

forgot to add in the details of what was working, the cameras are:
2 x DCS-4602EV
DCS-2210
DCS-2310L
2 x Reolink RLC-410-5MP (the path is bit strange for this but ‘other’ worked),
they are all wired with POE,

Euan

1 Like

I have the same problem DCS-4602EV
Camera settings :
Authentication: none
RTSP Port:554
Access Name for Stream1: live1.sdp
IP: 192.168.1.190

In add new camera in animus:
IP:192.168.1…190
Port:554
Path:
Her on path i have tried a bunch om different ways, nothing works
According to manual i am supposed to use:
For instance, live1.sdp can be
accessed at rtsp://x.x.x.x/video1.sdp
Camera responds in webinterface when surfing to ip above.
Animus cannot view the stream, whats wrong?
/Lelle

Have you tried typing /live in the path, without the .sdp?
I posted a screenshot in another post showing how to add the different info in Animus Heart: Adding Wyze camera

Also read this somewhere:

The default name is video#.mjpg, where # is the number of the stream

1 Like

Thank you Vigge
Tried to install an rtspwiever app to my iphone. Give it the followining adress:
rtsp://192.168.1.190:554/live1.sdp
And it works in the phone, but not in Animus.
Entered the console to try to find out how devices, each field is mapped.
When listing devices, camera wasnt included. I go back to interface to do the last step, and it works.
Conclusion:
I must have entered wrong ip or something the first times i tried. When trying even more i stopped at the preview stage and there it did not work.
So dont trust preview stage, it migth work anyway.

2 Likes

Awesome, thank you for sharing your conclusion also!

Yes, don’t trust the preview stage always. Also, give it some time because it does not always show immediately. This can be helpful to many taking on the task of adding cameras.

1 Like

If the cams are high resolution be careful because it can utilize the wifi if the Animus is connected like that.
Learned that the hard way when I wasn’t able to connect to it via the app anymore, and in the end I had to delete all my IP cams from the Animus.

Have Reolink 5MP Poe Cams and within 20 min it had already download 1GB of data, and with the Animus wifi chip (around 70Mbit connection) its not able to keep up the data from the cams.