Welcome to Animus Talk

This is where users of Animus Heart can share ideas,
solve problems and inspire fellow enthusiasts.

Animus Heart?

Mesh not working?

Hi!

Last week I was a happy new Animus user. I have a big z-wave network at home with another system, but I really like Animus now that I set it up in my summercottage.
Now I ran into problems though.

Added one Zwave device (Aeotech Nano Dimmer) and a few 433 devices some time ago… Worked great!

Now I have bought a Telldus plugin switch and a Popp IP 44 outdoor ON/Off socket…
These will be some way from the Animus, so counted that the mesh network would help me.
But it just doesnt work. I can add the devices when they are in the same room, and control them…
But when I move them 2 rooms away its impossible to add them. Or in case they were already added impossible to control them).
The Aotech sits in the middle between them, and I dont see any difference if its powered off or on. VERY strange!

Im not talking any great distances here. In total maybe 7 meters from the Animus to the place I cant control the two devices. I have a 433 device in the same spot and it works great.
And the Aotech sits in the middle…
I was hoping for WAY longer range with Zwave plus, but even worse is that the mesh doesnt seem to work. My goal is to have the devices even further away, but doing tests with as short distances as possible.

Any clues what goes wrong here?

I dont use z wave by myself but i did a search on google and found something i think that you maybe could find interesting. Its about z-wave mesh and how to get the best out of it… It’s written for hubitat but seems logical for animus heart as well.

Opps… forgot about the link… :lying_face::zipper_mouth_face:

it was actually this; “Z-Wave devices build this communication mesh automatically, but it is not instantaneous. You MUST give your Z-Wave mesh time to establish itself BEFORE automating your Z-Wave devices. Automating devices too quickly can lead to dropped device and other issues down the road.” that caught my eyes.

But it seems very strange with only like 7 meters of range… I know for sure that there are quite many in here that uses many z-wave devices without rangeproblem :confused:

Link? I have goggled a lot as well, and it should be automatic as I understand it, even if you can tune it. Tuning should not be needed in this case though…

Thanks for the link.

Yes, I know about the time, and I pressed rebuild, and waited. To no luck.

And im one of the persons that have no problem with range in my other house…

1 Like

Is it possible to narrow down the problem and try some other devices? I’m afraid i’m out of ideas :thinking:
Have you any thoughts @Vigge?

And i forgot to say, Welcome @jonas1 to the forum! :slight_smile:

Thanks! Very high hopes for this device!

I have been trying to narrow down the problem by replacing units, but its all so random. The only thing thats the always in the equation is the Animus…

And: After rebooting the Animus this morning all Zwave devices was gone from configuration!. So something really fishy is going on… Do you think there might be something wrong with my Animus and I should get it replaced?

Added information: When I try to add the zwave devices in again it says its not possible as the “Zwave package is starting up”. So I guess thats why I cant see the devices now. But should this “booting” take so long time? I restarted the complete device 2 hours ago…

Okey, so now it start to so sound a little fishy. I think you should take direct contact with the support.

https://animushome.atlassian.net/servicedesk/customer/portal/1

1 Like

When you receive this message then it means the z-wave packages wasn’t able to start at all after many attempts so the Heart will give it up. You need to restart the Heart to give it a second try.

Did you try the Heal network button in Z-wave package settings? That one will fix the routing so that your mesh network can be fully utilized and the range “extended”.

1 Like

Yes, i tried the heal button, and let it run all night… Animus did work after a restart as well.

Is there any way to visualise the network route, so one understand what node that dont work well?

At first it did work well, but now it doesnt work even with two repeaters inbetween the two nodes… Can it have jumped down to Zwave non-plus for some reason (all parts are Zwave plus…).

I have played around more and it does indeed seem like the mesh is working, but the range is terrible…
4 meters and a thin wall is where I get into trouble…

Ok then some node is holding the network heal.

You can actually view the routing tables through the terminal to see if they are good. Go to Developer Portal (http://<your_heart_ip>/heart/system/terminal/index.html). In the left side you have a terminal and on the right side you have a live log. Type the following in the terminal

> enter zwave
> network list

You can start a network heal with the following command as well

> network healnetwork

And view in the log which node is currently being worked on.

2 Likes

Excellent. This showed something is really wrong.
It claims that a node (Telldus) that is not reachable directly from the animus, is reachable from another node. So all correct.
BUT: That intermediate node marked is the wrong one! Its farther away from the Telldus than the animus. There is a node of the same brand that woud be the perfect intermidiate, but this node is only listed as neighbor. And Telldus is not responding, even though the Animus UI claims it is reachable…

And I had this set up for 48 hours fixed and done network heals. So it should be stable.

After two hours of Network heal in the terminal I only got this output:
info 2019-05-05 12:38:03 #bid107 - Starting to heal network
info 2019-05- 05 12:38:03 #bid107 - Heal network - syncing nodes

info 2019-05-05 12:38:03 #bid107 - ZNode 0: No handler for this zippacket, dumping the data on debug

info 2019-05-05 12:38:13 #bid96 - Initiating new request to localhost:80 with id 06ad2ffffe55558e-00002509-000f5600-679300657c31967e-50c1f640 for session: 2791

Is something wrong with my Animus ? Or just a bug?


update after 9 hours: I can not start a new heal network as its “already in progress.”. Also no output in terminal… :frowning:

Any clue how to get support from Animus? I opened a ticket last week, but no reply at all…

I’ve had contact with them using the form on their website, which I assume is the one you refer to.
https://animushome.com/en/support

1 Like

Correct. Well, just have to wait to hear if they reply…

Edit: Got reply now. Lets see where it leads…

1 Like

I have experienced the exact same problems as @jonas1 describes. I have played around quite a lot with the network commands in the terminal and changing position of devices to try to improve the network etc, etc.

My experiences in summary:

  • Shorter direct range with the Animus that expected. Shorter than with RF433.
  • The heal function is not stable and often gets stuck on the same error message as @jonas1 describes (ZNode 0: No handler for this zippacket, dumping the data on debug)
  • The heal command seems to work somewhat randomly, generating mesh network where nodes are abandoned “route via: no working route”. Or setting up routes that are obviously not the optimal ones. While repeating the networkheal command different results are generated almost every time with different neighbour list, routes and different nodes being abandoned.

What is also quite bothering is that in some cases the automations using a device that becomes unreachable breaks as the device becomes “device not available”, resulting in that you need to go through all automatons using that device and manually fix them once you’ve got mesh network working again.

As my experiences are the same as @jonas1, I would appreciate if the Animus staff continue to use the forum for the further handling of this issue so it can be followed by more users.

If there would be a way to manually set up static routes and avoid the automatic heal process, I think that would be helpful in some cases.

1 Like

Thanks for the “support”. I thought I was going crazy!

My setup is in a cabin Im not often is in, so havent been able to play around much.

But today im here, and testing stuff I got from Animus support earlier, among them a new zwave firmware. End result:
One of the nodes got a correct route, earlier it was unreachable. But another node still have the wrong route…

One step in the right direction, but for sure not solved. I will now try to remove some nodes and add them back to see if this fixes the routing tables…

After playing around my routing table now is correct!!!

But: It seems its not used!
I walked around with a long cable with a node that was supposed to route though another node (Lets call the routing node 15, as this is the number it has).
I could not make a connection until I was 3 meters from 15.
Very disappointing range!

But… I then tried turning node 15 off, and I got the same coverage range!!!
Thus it was not using the routing table, but going direct from the Animus all the time, even though the routing table was set up in another way…

Have you seen something similar @joakim ?

Something is VERY broken… Works fine for direct connections, but with mesh… Not at all!

Hi guys,

We can continue the discussion here and try to solve this.

  1. When you receive the message while running Heal Network ZNode 0: No handler for this zippacket, dumping the data on debug then the Heart received a weird message by a node and it will get stuck. You need to reboot it.

  2. We have seen this happen for some users but we haven’t been able to capture what data is being sent that makes it fail like this. We will have some more debug information printed out to capture this and I would be glad if you could install it on your Hearts.

  3. Let me get back to you regarding setting static routes.

  4. We will double check the routing soultion and why it seems so “random”, much could do with how those nodes report as well. @jonas1 could you try with a smaller set of nodes and see how the routing behaves as you add more nodes to your network? If it’s possible don’t include the aeotec nano dimmers initially.

  5. The range should be much better. I was able to try 15meter indoor just now without any problem. Which version do you have on your z-wave firmware? Go to Settings->Package Controller->Z-wave Package.

Since this post will become trial and error please keep some structure and information that is only relevant to the z-wave network heal. Let’s do this! :muscle:

2 Likes

An even smaller set of nodes than the 4 I have? (whereof one is 100% unreachable as it is now?)

I can turn them off, but please let me know what setup you would like me to try? I thought I was down to the bare minimum in what is needed to have some kind of mesh network… Im not at that house during the week however. I have remote access, but I cant disconnect stuff physically of course…

Do you just want to turn them off, or also remove them from the Animus?

I use the beta you gave me:
image