Welcome to Animus Talk

This is where users of Animus Heart can share ideas,
solve problems and inspire fellow enthusiasts.

Animus Heart?

Telldus Z-Wave PowerSocket model 313510

Hi,
just tried to include a Telldus Power Socket with energy meter (313510). Seems to have worked good, but at the end of the inclusion, I got a very long code I was supposed to verify. Where do I find that?!
I know that S2 devices has this, but it is then printed somewhere. This code is nowhere to be found on the package. A bit perplexed, is this the Heart acting up or is there a code somewhere?
Thanks

Hi there,

for my Aeotec Switches it is printed on a sticker at the package and also, very small, on the inside of the plug.

Or look at the picture here.

Edit says: scroll down in this document to the technical data, where you will find the solution. :slightly_smiling_face:

1 Like

Hi there,
thanks for trying to helpā€¦
I did as you asked, looked through the technical data, but sadly, did not find the solutionā€¦?

In the documentation it says S2_UNAUTHENTICATED. Can it be that Animus not support that.
I donā€™'t know how it looks like in the Heart, but are you blocked?

See: https://www.silabs.com/community/wireless/z-wave/knowledge-base.entry.html/2018/12/21/why_use_s2-unauthent-uj37

1 Like

Hi, thanks.
What happens is this;

  • I set the Heart in inclusion mode
  • press the button on the Telldus 3 times (within 1.5 s)
    That starts the inclusion process and shows;
    S2_1
    And after hitting ā€œAcceptā€, it shows this;

    Which makes be think it does, but I cannot find the code to verify with anywhereā€¦ No sticker, on or inside the package (any part of it), nor on the device itself or the included manualsā€¦
    Really strange. As shown in the technical manual, it is S2 enabled, but any such markings are just not thereā€¦

Maybe that why its less secured. You have to trust that its your device you are including. Like one time authorization code. So only Accept the code.

Found this:
S2 includes ā€˜unauthenticated S2ā€™ and ā€˜authenticated S2ā€™, where the authenticated devices has a unique authentication code on them.

1 Like

Hi,
Hmā€¦ Maybe the meaning of ā€œunauthenticatedā€ here is just the fact that there is no code to authenticate/verify with, or for sure, yes. But still strange. In that case I think the Heart should just accept itā€¦ Still donā€™t get it, but that shed some more light on it, thanks! :slight_smile:

1 Like

Yeah, The UI can be more intuitive in this case.

1 Like

Right, so you can simply confirm, as thereā€™s no code you have to enter.
After including you will find the device like that:
s2_u
ā€¦which seems to to be ok and the nature of S2_UNAUTHENTICATED.

I had the same trouble when including my first Eurotronic device, I think itā€™s a simple way for the manufacturer to meet the Z-Wave mandatories.

1 Like

Thanksā€¦ I knew there were something fishy. I wonder why the :animusheart: even shows the code and asks for verification. In case of S2 Unathenticated I think this step should be hidden/removed and the code auto accepted. But wise from all these months, that will probably not happen anytime soon, if ever. Anyway, now on to controlling my washing machine! (actually looking at your solution as a staring point) :slight_smile:

Like @magnus2 said, this is what S2 Unauthentcated is about, when accepting the code it is taken as a comfirmation that you hold the device in your hands at this very moment (though thereā€™s no reference code).
I guess, an auto-skip would not meet the Z-Wave standards anymore. :roll_eyes:

Then there is not much of a difference between S2 Authenticated and S2 Unauthenticated, why bother to have them both? Pure economical reasons? Legacy reasons? I mean, when accepting a code you cannot verify to be yours, and it could potentially be your neighbors for all that is known at that pointā€¦ Likeliness for that is another thing though, but in principal, you cannot be 100% sure. Since you have no means of verifying, accepting it seems like an unnecessary step, standard or not. :slight_smile:

1 Like

Since S2 security is mandatory for manufacturers when creating new devices for a few years now, I assume that itā€™s an econimcal decision. :thinking:

Agreed, you can never can be 100% sure, but think of all the requirements to be met for your neighbour to include a device to your network. :crazy_face:

Whatever the Z-Wave Alliance decides in their endless wisdom. :innocent:
Still you can uncheck the box during the inclusion process and use S0 instead of S2.

1 Like

Sure and agreed. I donā€™t dispute the facts, just questions them a littleā€¦ :slight_smile: As you say, since S2 has been mandatory for a few years now, I am surprised that S0 is still offered as alternative when including devices that offers higher security. Heck, even Unauthenticated S2 is a bit old really. But sure, needed for backwards compatibility. As suggested, Z-Wave Alliance probably has a plan for all this somewhereā€¦ :slight_smile:

Right, just found this:

What I didnā€™t know, that S2-devices cannot be controlled by lower security devices.
I wonder if this could have something to do with my persisting problems???

1 Like

Good finding! As usualā€¦

I do have an issue with the plug though. By unknown reason it shuts off power after just a minute or so. First I thought it had to do with any automations I was trying, but after first disabling them (one virtual switch and one automation), the problem was still presentā€¦ So I deleted them, but no. It still shuts off. Rebooting the Heartā€¦ Did not helpā€¦ :animusheart: thinks the plugs power is on, but is actually off. Plug is still includedā€¦ Will exclude and see if problem persists, then it may be hardware or a bad inclusion (perhaps)ā€¦ If something would be easy once in a while, but hm, no.
:thinking: Even after exclusion it shuts off after 1:16 secondsā€¦ What else is there? Will try a hardware reset of the plug if possibleā€¦ I donā€™t think the :animusheart: is to blame, but surely donā€™t get what I missā€¦ It could be defective, even though unlikelyā€¦
Ideas?

I have now completely removed any connection to the :animusheart:, resetted the plug and it still acts up, or shuts off after ~1:15 secs. I donā€™t see what I miss hereā€¦ I have two more I could try

Just another weird theory regarding my old problem, I alread had the idea of S2 causing my issues in a former topic.

Regarding your current troubles, one of my Aeotec switches was DoA, so maybe consider a broken device.
What also happens from time to time, until now only 2 switches are affected, that they detect an overload for no reason and thus turn into a failure state until being resetted.
So maybe have a look at the power managegment:

Consider setting parameter 1 to the value 0, but only if the switch keeps turning off when no load is attached.

1 Like

Hi,
When testing with a lamp, it stays on and seems to work. It appears to be the washer or the socket in the bath room that fools it somehow. By looking at the statistics, there donā€™t seem to be any overload going on, in that case I guess it should show as in your picture, but did not. It did just cut power, but the :animusheart: still reported it as ON, even after refresh (when included of course). Difference between the bathroom and living room is that sockets here are not grounded. Will have to test in the kitchen as wellā€¦ Peculiar problemā€¦

Hm, what happens when you click the refresh button in the Heartā€™s GUI?

I also have a rather old installation, I really hope this is not the reason.

1 Like